ネットワークスペシャリスト - SE娘の剣 -

ネットワークスペシャリストの試験対策サイトです。ネットワークスペシャリスト試験の合格体験談、合格のコツ、過去問解説、
基礎知識などの情報を掲載します。試験対策セミナー・研修も行っております。 ネットワークスペシャリスト試験対策なら
左門至峰の最も詳しい過去問解説「ネスペ」シリーズ(技術評論社)で!!

カテゴリ:11.ルーティング > 11.3 RIP

女性腕組み

RIPの特徴をいくつか書きます。
・ディスタンスベクター型・・・メトリック値(ルータの数)で最短経路を判断する。(デメリットである場合もある)
ディスタンス(距離)とベクター(方向?)なので、距離と方向という考えもできる。

・ホップ数を使う。最大ホップ数は15。
・30秒毎に経路情報を交換する(レギュラーアップデート)。UDPによるブロードキャストで実施する。
・・・

これくらいで十分でしょう。試験ではそれほど深い内容は問われません。
過去問に詳しい事例が載っているので紹介します。
http://www.jitec.ipa.go.jp/1_04hanni_sukiru/mondai_kaitou_2011h23_1/2011h23tokubetsu_fe_pm_qs.pdf

◆以下は詳細情報です。
※テストには出ないでしょう。参考としてください。

・レギュラーアップデート(30秒):UDPを利用したブロードキャスト。RIPv2ではマルチキャストに改良されている。
・ホールドタイマ(180秒)間、レギュラーアップデートを受信しなかった場合、このルーティング情報は無効と判断する。※180というのはレギュラーアップデート(30秒)を6回分である。
・ガベージコレクション(120秒)を待ってから、ルーティングテーブルから削除する
・スプリットホライズン:ルーティングのループを回避するために、受信した側へはルーティング情報を流さない。Split Horizonとは水平分割という直訳になるだろうか。どっちが垂直でどっちが水平かは分からないが、とにかくルーティングを送信する側と受信する側で分割するという意味だと思う。分割した上で、流す方向と流さない方向を決める。

・トリガーアップデート:30秒のレギュラーアップデートをまたずに、障害
などのトリガーによってUpdateする。とはいっても、ホールドタイマとガーベジコレクションの時間は必要であるため、迅速なコンバージェンスは不可能。所詮30秒以内の改善にしかならない。
これは、コンバージェンスの高速化を狙っているのではなく、ルーティングによる不具合をなくすために行っているのである。

・ポイズンリバース:Poison Reverse 逆方向にPoison(到達不能を意味するメトリック16という”毒”)を流す。目的はスプリットホライズンと同じだと思う。流さないのがスプリットホライズンで、意図的にNGを流すのがポイズンリバース。

RIP2はRIPのversion2である。
では、RIP2による改良点は何でしょう?
女性直立

これは分かりますよ。
「サブネットマスクに対応した」
正解!!
最低限そこは覚えましょう。
また、RIP2はRIPと互換性があります。

以下に違いを整理します。

◆RIPと比べたRIP2の改良点
1) サブネットマスクに対応した。 
2) レギュラーアップデートなどの情報交換をRIPではUDPを利用したブロードキャストで行っていたが、RIPv2ではマルチキャストに改良された。
3) 認証機能(パスワードを確認してからアドバタイズをうける)

過去問で力試しをしてください。正解以外の選択肢に関しても、なぜ違うのかを説明できるようにしましょう。
【H18NW午前 問30】
RIP及びRIP2の仕様に関する記述のうち、適切なものはどれか。
ア RIPでは情報交換にブロードキャストを使うが、RIP2ではユニキャストを使う。
イ RIPと同様にRIP2でもサブネットマスクを運ぶ機能がある。
ウ RIPには最大15ホップまでという制限があるが、RIP2では制限が拡大されている。
エ RIPには認証機能がないが、RIP2では更新情報のメッセージごとに認証ができる。

正解:エ

◆ポイント
・RIP2による変更点を覚えましょう
・RIPとRIP2は互換性があります

ルータの経路制御方法について、過去問(H23FE午後問4)には以下のように述べられている。
ルータは,二つ以上の異なるネットワークをまたいだ通信における通信経路の選択を,ルータ内の経路制御情報を格納したテーブルに基づいて行う。
このテーブルが、ルーティングテーブルである。
RIPの場合の例を、この過去問を基に紹介する。
まず、構成図は以下である。
route
送信先ネットワークアドレス転送先ルータのIPアドレス 距離
10.0.0.0/24-0
10.0.1.0/24 -0
10.0.2.0/2410.0.1.21
10.0.3.0/2410.0.1.22
また、次の補足もある。
←転送先ルータのIPアドレスの-は,送信先ネットワークとこのテーブルをもつルータが,直接つながっていることを表す。
←ルータ1がネットワークCに接続された端末あてのパケットを受信したとき,そのパケットはIPアドレス10.0.1.2のルータ(ルータ2)に転送すればよいことを表す。

RIPに限ったことではありませんが、ルーティング情報を受信はするが、送信はしないインターフェースを設定することができます。これを、受動的な(passive)という意味で、パッシブインターフェースと言います。
以下の図をみてください。ルータ1とルータ2はRIPが動作して(図 法経路情報を交換しています。(図◆法0貶、PCはもちろんRIPは動いていません。ルーティングの設定としては、デフォルトゲートウェイを設定しているだけです。ですから、PCに経路情報を流す必要はありません(図◆法ですから、ルータのP2は、パッシブインターフェースにして、RIPによる無駄なトラフィックを流さないようにします。

※過去問(H29秋NW午後橘3設問3(2))では、パッシブインターフェースの動作の特徴として「Helloパケットを出さない」とありました。
123

WANを冗長化するために、RIPによるWANの設計はどうしたらいいだろうか?
線を2本にするのが基本。では、ネットワーク設計は?
4

こんな感じでしょうか。
rip
このままRIPをさせると、RIPは単にメトリックしか見ないので、2つの経路が同じコストになる。なので、通信としては推奨されない。
なので、片方をバックアップとして、優先度をさげる必要がある。
ただ、Ciscoなどの機器の場合、自動で経路を分散して通信をしてくれる。ただ、どっちの経路を通っているかなどはわかりにくい。

Ciscoでのルータの設定をやってみます。
インターフェース(IF)の設定から順に実施します。

■1.IFにIPアドレスを割り当てる
(1)設定概要
以下の図のように、LAN側に192.168.1.254/24、WAN側に172.16.12.254/24のIPアドレスを割り当てます。
cisco
ここで、注意点です。Cisco892の場合、インターフェースの0~7番(FastEthernet0~7)はスイッチングハブとして動作します。よって、この8つのポートで1つのIPアドレスを持ちます。このとき、IPアドレスは、FastEthernet0~7を束ねたvlan1に設定します。

(2)設定
Router#conf t
Router(config)#int vlan 1
Router(config-if)#ip address 192.168.1.254 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int gigabitEthernet 0
Router(config-if)#ip address 172.16.12.254 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#end

(3)通信の確認をしてみましょう。
192.168.1.0/24のセグメントのPC(192.168.1.11)から、172.16.12.0/24のPCにpingを送信しましょう。PCのデフォルトGWはルータを向けましょう。また、PCのOSやウイルス対策ソフトのなどのパーソナルFW機能でpingが拒否されている場合があります。一時的にOFFにしておきましょう。

■2.NATをしてみよう。
(1)概要
192.168.1.11のIPアドレスのPCを、外からは203.0.113.11に見えるようにしましょう。
つまり、203.0.113.11への通信をルータで192.168.1.11にNATします。

(2)設定
設定は以下です。
Router(config)#interface vlan 1
Router(config-if)#ip nat inside
Router(config-if)#exit
Router(config)#int gigabitEthernet 0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#ip nat inside source static 192.168.1.11 203.0.113.11
Router(config)#end

(3)設定確認
\瀋螢灰泪鵐
NATが設定されているかを、以下のコマンドで確認します。
Router#sh ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
--- 203.0.113.11       192.168.1.11       ---                ---

Ping疎通
172.16.1.0/24のPCから203.0.113.11にPingを打ってみましょう。PCの本当のIPアドレスは192.168.1.11ですが、pingが届くと思います。

Wiresharkで確認
ルータの前後でパケットの宛先が変化していることを確認してみましょう。

だ瀋螢灰泪鵐匹燃稜
NATテーブルに変換の情報が記憶されていることが分かります。
Router#sh ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
icmp 203.0.113.11:1    192.168.1.11:1     172.16.12.1:1      172.16.12.1:1
--- 203.0.113.11       192.168.1.11       ---                ---

■3.対向のルータと接続してみよう。
(1)設定概要
以下の図のように、対向として、LAN側に192.168.2.254/24、WAN側に172.16.12.253/24のIPアドレスを割り当てます。
cisco2
(2)設定
Router#conf t
Router(config)#hostname R2  ←分かりやすいように、ルータのホスト名をR2にします。
R2(config)#int vlan 1
R2(config-if)#ip address 192.168.2.254 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int gigabitEthernet 0
R2(config-if)#ip address 172.16.12.253 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#end

(3)通信の確認をしてみましょう。
pingの疎通確認
pingを順に送信し、ルータのLAN側、WAN側、対向ルータのWAN側、LAN側、対向のPCのどこまで届くかを確認してください。恐らく、ルータのWAN側までしか届かないと思います。

▲襦璽謄ングテーブルの確認
以下が主なものです。自分のルータのネットワークしか見えないことでしょう。
R2#sh ip route
C        172.16.12.0/24 is directly connected, GigabitEthernet0
C        192.168.2.0/24 is directly connected, Vlan1

(4)スタティックルーティングの設定を入れます。
2台のルータの両方に必要です。

R1(config)#ip route 192.168.2.0 255.255.255.0 172.16.12.253
R2(config)#ip route 192.168.1.0 255.255.255.0 172.16.12.254

すると、スタティックルートが追加されるのが分かります。
R2#sh ip route
C     172.16.12.0/24 is directly connected, GigabitEthernet0
C     192.168.2.0/24 is directly connected, Vlan1
S     192.168.1.0/24 [1/0] via 172.16.12.254

(5)通信の確認をしてみましょう。
pingを順番に打ってみましょう。

■4.RIPで対向のルータと接続してみよう。
(1)設定概要
ダイナミックルーティングプロトコルであるRIPを動作させます。

(2)設定
R1の場合は、自身のインターフェース
のネットワークを記載します。
router rip
network 192.168.2.0
network 172.16.0.0  ←クラスフルなので、こうしてください。

(3)通信の確認をしてみましょう。
pingの疎通確認
pingを順に送信し、ルータのLAN側、WAN側、対向ルータのWAN側、LAN側、対向のPCのどこまで届くかを確認してください。

▲襦璽謄ングテーブルの確認
RIPで交換した経路であるという意味を表すRの行を見ましょう。
対向のネットワークが見えているはずです。
R1#sh ip route
R     192.168.2.0/24 [120/1] via 172.16.12.253, 00:00:19, GigabitEthernet0

RIPngに関して過去問(H28春AU午前玉18)では、「ネットワークの経路制御プロトコルのうち,IPv6ネットワークに使用され,距離ベクトル方式を用いているもの」と述べられています。ポイントは、IPv6対応という点です。RIPのプロトコルにおいて、IPv6でのルーティングプロトコルに対応したものがRIPngです。参考ですが、ngはNext Generationの意味です。

スポンサードリンク

↑このページのトップヘ