ネットワークスペシャリスト - SE娘の剣 -

ネットワークスペシャリストの試験対策サイト(by 左門至峰の株式会社エスエスコンサルティング)です。ネットワークスペシャリスト試験の 勉強方法、合格体験談、合格のコツ、過去問解説、基礎知識などの情報を掲載します。試験対策セミナー・研修も行っております。 ネットワークスペシャリスト試験対策・勉強なら左門至峰の最も詳しい過去問解説「ネスペ」シリーズ(技術評論社)で!!

実際に設定してみよう

1.Ciscoに接続してみよう

1.Cisco機器に接続してみよう

Ciscoの機器に接続してみましょう。

(1)設定に必要なもの
①設定用のPC
②設定用のターミナルソフトウェア(Tera Termなど)
③コンソールケーブル(Cisco機器に附属しています。)cisco_console
④(必要に応じて、)USBシリアル変換ケーブル 
最近のパソコンはD-sub9ピンのシリアルポートが存在しないものが増えています。そこで、USBポートをD-sub9ピンに変換するケーブルを使って、PCとFortiGateのコンソールポートを接続します。
henkan

製品例として、以下があります。1617円(2019.7.29現在)ですので、比較的安価です。


ドライバーなどは、以下からダウンロードできます。
https://www.buffalo.jp/support/download/detail/?dl_contents_id=62142


(2)接続後の設定
①PCでターミナルソフトウェアを起動します。以下は、代表的なソフトウェアであるTera Termの画面です。
②シリアル通信用に認識しているCOMポートを選択します。上記の画面では、COM8を選択しています。
※必要に応じて、シリアルポート設定の「スピード」が9600になっていることを確認します。★基本はデフォルトのままでいいので、設定変更不要)

(3)初期化されたスイッチの設定 ~設定のモードに入る
         --- System Configuration Dialog ---

 

Enable secret warning
----------------------------------
In order to access the device manager, an enable secret is required
If you enter the initial configuration dialog, you will be prompted for the enable secret
If you choose not to enter the intial configuration dialog, or if you exit setup without setting the enable secret,
please set an enable secret using the following CLI in configuration mode-
enable secret 0 <cleartext password>
----------------------------------
Would you like to enter the initial configuration dialog? [yes/no]:n ←noを意味するnを入力してEnter
Switch> ←コマンドを入力するモード(ユーザ EXECモード)が表示  ※Switchというのは、このスイッチのホスト名
Switch>enable  ←特権モード(特権 EXECモード)に変更
Switch#  ←#の表記に変更
Switch#conf t  ←設定を変更するモード(グローバル コンフィギュレーションモード)に変更
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)# ←(config)#の表記に変わる

(4)モードについて
Ciscoのモードには、いくつかのモードがあります。
以下を参照にしながら整理します。
https://www.cisco.com/c/ja_jp/td/docs/sw/lanswt-access/cat2960swt/cr/004/comref-book/intro.html
 
コマンド モード 補足 プロンプト 次のモード 終了
ユーザ EXEC 最初の状態 Switch> 特権 EXEC モードを開始するには、 enable コマンド logout
特権 EXEC Configを見るなどの特権モード Switch# グローバル コンフィギュレーション モードを開始するには、 configure コマンド disable
グローバル コンフィギュレーション 設定するモード Switch(config)# インターフェイス コンフィギュレーション モードを開始するには、 interface コンフィギュレーション コマンド exit
end 
インターフェイス コンフィギュレーション interfaceを設定するモード Switch(config-if)# - end


▼exitとendの違いを実演で紹介します。

Switch>enable
Switch#conf t
Switch(config)#end  ←exitでも同じ
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#end ←特権EXECモードへ戻る
Switch# 
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#exit ←1つ前のモードに戻る
Switch(config)# 

2.初期設定
初期設定(L2SWの場合)※L3も基本的には同じです。

(1)IPアドレスの設定
L2SWにはIPアドレスを1つしか設定できません。

Switch#conf t
Switch(config)#int vlan 1 ←Vlan1の設定をします。
Switch(config-if)#ip address 192.168.1.201 255.255.255.0 ←IPアドレスを192.168.1.201/24に設定します。
Switch(config-if)#no shutdown ←このVlan1を有効にします。
Switch(config-if)#exit
Switch(config)#

(2)LANケーブルからアクセスする設定
コンソールケーブルを使わずに、LAN経由でアクセスする方法として、TelnetまたはSSHがあります。
セキュリティ的には好ましくありませんが、検証などではtelnetが簡単なので、お勧めです。
①Telnetの設定
以下は、パスワード無しで、しかも特権モードで入れる設定です。
Switch(config)#line vty 0 4
Switch(config-line)#privilege level 15
Switch(config-line)#no login
Switch(config-line)#end
Switch#

②SSHの設定
Switch(config)#enable secret passwd ←SSHでログイン後には、enableパスワードを設定しておく必要があります。
Switch(config)#username user1 password 0 passwd ←ユーザ名とPWの設定
Switch(config)#ip domain-name seeeko.com ←ドメイン名の設定(SSHの場合はサーバ証明書を発行するので、FQDNが必要。ホスト名はすでにSwitchとして設定されている)
Switch(config)#hostname sw1 ←ホスト名(このスイッチの名前)はデフォルトでもいいが、ルータの場合はhostnameを変えないと怒られる。※ここでは設定しない
Switch(config)#crypto key generate rsa ←RSAの暗号鍵を作成
How many bits in the modulus [512]: 1024 ←鍵の長さを指定する。SSHv2を使うには、768bits以上にする必要があるので、ここでは1024を指定
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

Switch(config)#line vty 0 5 ←0-5までの6人がログインできるように
Switch(config-line)#login local  ←作成したローカルのアカウントでログインできるように
Switch(config-line)#end
Switch# 
3.基本的な設定
①設定したConfigを確認する
Switch#sh run ←設定を確認するコマンド 正確にはshow running-config

先ほどの設定の場合、以下が設定されていることを確認しましょう。
enable secret 5 $1$o1d.$RU9m5URpx/Th8I8kDkIjv0
!
ip domain name seeeko.com
!
username user1 password 0 passwd
!
interface Vlan1
 ip address 192.168.1.201 255.255.255.0
!
line vty 0 5
 login local
 transport input all

 

②設定の保存
Switch#write memory

③再起動
Switch#reload
→Save?と聞かれたら n
→Proceedと本当に実行するかを聞かれたら y

④設定の削除
削除する設定にnoを付ける。たとえば、ルーティングを削除する方法
Router#conf t
Router(config)#no ip route 192.168.2.0 255.255.255.0 172.16.12.253
Router(config)#

⑤設定の初期化
コマンドはいろいろありますが、write eraseでできるなら、コマンドが短いので楽です。
Router#write erase
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]←Enterキー
Erase of nvram: complete
Router#reload
System configuration has been modified. Save? [yes/no]: no
Proceed with reload? [confirm]  ←Enterキー

※スイッチの場合はVLANを削除する必要があるかもしれません。
4.DHCPサーバの設定

Switch#configure terminal
Switch(config)# ip dhcp pool seg1  ←任意の名前を付ける
Switch(dhcp-config)# network 192.168.1.0 255.255.255.0 ←払い出すネットワークとサブネットを指定
Switch(dhcp-config)# default-router 192.168.1.254 ←払い出すデフォルトゲートウェイを指定
Switch(dhcp-config)# dns-server 8.8.8.8 ←払い出すDNSサーバを指定
Switch(dhcp-config)#exit

※スイッチでDHCPサーバの機能を有効にしても端末にIPアドレスが払い出されない場合があります。そんな場合は、スイッチにIPアドレスを設定しているかを確認してください。

5.具体的な設定(インターフェースやVLANなど)

具体的な設定はここでは解説しませんが、いくつかの記事に分けて記載しています。ご参考まで。
①VLANの設定
 VLAN - ネットワークスペシャリスト - SE娘の剣 - 

②インターフェースの設定からRIPまで
 RIP(Routing Information Protocol) - ネットワークスペシャリスト - SE娘の剣 - 

③スイッチにおけるIFのIPアドレスとデフォルトゲートウェイの設定
CatalystのL2スイッチの場合、IPアドレスは1つだけです。なので、IPアドレスはIFに設定するのではなく、VLANに設定します。今回はデフォルトVLANのvlan1に設定します。ここでは、デフォルトゲートウェイやDNSサーバも指定しています。
Switch(config)#int vlan 1
Switch(config-if)#ip address 192.168.1.200 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#ip default-gateway 192.168.1.254
Switch(config)#ip name-server 8.8.8.8

2.TeraTermを使ってみよう

TeraTermのダウンロードおよびインストール、接続方法を紹介します。

(1)ダウンロード
 ①以下のサイトにアクセス
  https://ja.osdn.net/projects/ttssh2/releases/

 ②ファイルの選択
  「ダウンロードパッケージ一覧」からファイルを選びます。
  exeファイルをダウンロードします。
  2019.6.28時点では、teraterm-4.103.exeという名のファイルをダウンロードします。

 ③ファイルの保存
  デスクトップなどのわかりやすい場所に、「名前をつけて保存」をします。

(2)インストール
 ダウンロードしたteraterm-4.103.exeをダブルクリック
 基本的には、デフォルトのままで次へで
 実行します。
 デスクトップにTeraTermのショートカットが作成されます。

(3)起動と実行
 TeraTermのショートカットをダブルクリックして起動します。
 LANを経由してSSH接続をする場合は、以下のようにします。
  ①TCP/IPを選択
  ②ホストに接続先のIPアドレス(たとえば192.168.1.201)を指定
  ③サービスはSSHを選択
  ※PCのシリアルポートから接続する場合は、「シリアル」を選択します。
teraterm