ネットワークスペシャリスト - SE娘の剣 -

左門至峰によるネットワークスペシャリストの試験対策サイトです。勉強方法、合格体験談、合格のコツ、過去問解説、基礎知識などの紹介します。

ネットワークスペシャリスト試験対策本「ネスぺR5」

ネットワークスペシャリスト試験の午後問題を深く深く解説した「ネスぺ」シリーズの最新巻です。11/15に発売です。

ネスペR5 -本物のネットワークスペシャリストになるための最も詳しい過去問解説ネスペR5 -本物のネットワークスペシャリストになるための最も詳しい過去問解説
左門至峰
技術評論社
2023-11-15

今年のネットワークスペシャリスト試験の問題も、非常に難しい問題が多かったと思います。ネットワークスペシャリストは、上っ面の勉強では合格が厳しいことを改めて感じました。

本の内容ですが、今回も全力で解説させてもらいました。是非、この本でネットワークスペシャリスト試験をしっかり復習していただき、次のネットワークスペシャリスト試験で、合格しましょう。

OSPF

1.OSPF(Open Shortest Path First)

1そもそも、OSPFはなぜ必要なんでしたっけ?RIPでも十分では?
この、コストという概念があるのが利点の一つである。RIPはホップ数という、ルータの数でしか経路制御ができない。100Mの回線と1Mの回線では、当然100Mを優先した経路制御が求められ、それを実現するにはOSPFが必要だ。

ではここで、過去問を中心にしたOSPFの基本的な内容を以下に述べる。

(1)OSPFとは

・過去問では、OSPFの経路選択に関して「経路選択方式は、エリアの概念を取り入れたリンク状態方式である。(H19NW午前 問28)」と述べている。※リンク状態方式言葉よりもリンクステート型アルゴリズムという言葉のほうが馴染み深いであろう。・過去問では、IPネットワークのルーティングプロトコルの一つであるOSPFの説明として「ネットワークをエリアと呼ぶ単位に分割し、エリア間をバックボーンで結ぶ形態を採り、回線速度などを考慮した最低コストルーティングを行うプロトコルである。(H20NW午前 問28)」と述べている。・中規模なネットワークで利用されることが多い。※何をもって中規模というかであるが、少なくともRIPは小規模。

(2)OSPFとエリア

OSPFでは,ネットワークをエリアと呼ぶ単位に分割します。目的は,ルータの負荷を軽減するためです。ネットワークの規模が大規模になると,経路情報が複雑で大容量になります。ルータにかかる負荷が増えて,転送速度や切り替わり時間が遅くなるなどの問題が発生します。その対策のために,エリア分割するのです。ネットワークスペシャリストを目指す女性SEハテナエリア分割はルータ単位ですか?
いえ、ルータのIF単位と考えてください。下のConfig(設定)例を入れているので、それをみてもらうと理解が深まるでしょう。同じルータ内でも、ネットワーク毎(=インターフェース毎)にエリアを分けることができます。Router(config-router)#network 192.168.1.0 0.0.0.255 area 0 ←ルータが持つセグメントを記載する。今回のエリアは0Router(config-router)#network 10.1.1.0 0.0.0.255 area 10

・各エリアは必ずエリア0とつながっている必要がある。

(3)LSA

・LSA(Link State Advertisement):リンクステート情報のアドバタイズ(広告)によって情報交換をする。・LSDB(Link State Databese):LSAによりLSDBという自分を中心としたリンクステートのデータベースを保有する。・ネットワークスペシャリスト試験の過去問(R3春NW午後1問2)では、LSAに関する出題があった。 

OSPFルータは,隣接するルータ同士でリンクステートアドバタイズメント(以下,LSAという)と呼ばれる情報を交換することによって,ネットワーク内のリンク情報を集め,ネットワークトポロジのデータベースLSDB(Link State Database)を構築する。LSAには幾つかの種別があり,それぞれのTypeが定められている。例えば,【 b:ルータ 】LSAと呼ばれるType1のLSAは,OSPFエリア内の【 b:ルータ 】に関する情報であり,その情報には,【 c:コスト 】と呼ばれるメトリック値などが含まれている。また,Type2のLSAは,ネットワークLSAと呼ばれる。OSPFエリア内の各ルータは,集められたLSAの情報を基にして,【 d:SPF 】アルゴリズムを用いた最短経路計算を行って,ルーティングテーブルを動的に作成する

LSAに関しては、R3までの過去問にて、問われたことがありません。LSAは1~11までありますが、すべてが使われるわけではありません。以下、代表的な3つについて、簡単に図と表で整理します。

種別 名称 生成者 内容 目的
LSA type1 ルータLSA 全ルータ ルータ自身に関する情報(接続情報やコスト) 自身ルータの経路情報を他のルータに伝達
LSA type2 ネットワークLSA DR エリア内ルータの接続情報 エリア内の経路情報をエリア内のルータに伝達
LSA type3 ネットワーク集約LSA ABR(Area Border Router:各エリアの境界ルータ) 各エリアの経路情報 エリア毎の経路情報を他のエリアに伝える


ここに記載したように、タイプ1が自分の情報を伝え、タイプ2が、タイプ1で得た情報をもとにLSDBを作成してエリア内に伝達、タイプ3がエリア外に伝えると考えればいいでしょう。

CiscoルータでLSAの状態を見てみましょう。
・1つ目がRouter Link Statesとなっていて、ルータ(Router)LSAの情報です。Link IDとして、ルータLSAを作成した2つのルータが記載されています。
・2つ目がNet Link Statesとなっていて、ネットワーク(Net)LSAの情報です。Link IDとして、ネットワークLSAを作成したルータ(IFが2つあるだけで、実際は1台)が記載されています。

R1#sh ip ospf database

            OSPF Router with ID (192.168.1.101) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.1.101   192.168.1.101   521         0x80000011 0x002792 3
192.168.1.102   192.168.1.102   281         0x8000000F 0x005E5A 3

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.1.102      192.168.1.102   1377        0x80000002 0x00E66E
192.168.1.102   192.168.1.102   522         0x80000001 0x00C532
(4)参考

これ以降はテスト対策以上に踏み込んでいるので、参考レベルで。
・リンクステート型アルゴリズムは、OSPFのほかにははIS-ISがある
・経路情報はマルチキャストまたはユニキャストで送信する。ここはRIPv1のブロードキャストより優れている。
・Ciscoは一般的に1エリアあたり50ルータを超えないことを推奨。
・OSPFはTCPもUDPも利用しない。独自のOSPF(89番)を利用する。
・ABR以外に、 AS間をまたぐルータであるASBR(AS Boundary Router)もある。

2.OSPFのコスト

(1)コスト

・OSPFの重要な概念として,コストがあります。コストは,回線速度に反比例した式で計算される値です。コストは,回線速度の大きい方が小さい値になります。たとえば,Ciscoルータの場合、デフォルトの10Mbpsの回線のコストは10で、100Mや1Gbpsの回線のコストは1です。ですから、OSPFでは、10Mbpsの回線と、100Mbpsの回線の2つがあれば、コストが小さい100Mbpsの回線を経路として選択します。

・OSPFでは、コストが小さい経路が優先される。また、同コストの場合、負荷分散される。(H14NW午前 問44を参照)◆ネットワークスペシャリスト試験の過去問より引用

OSPFでは,[ ア ]と呼ばれるメトリックを扱います。
(中略)
OSPFを使用する場合には,L3SW相互がOSI基本参照モデルの[ イ ]層によって通信できる必要があるので,IPパケットを中継する方式では駄目です。OSPFでのブロードキャスト可能なネットワークにおける経路制御用の通信はIPマルチキャストであり,IPアドレスの先頭バイトの値が[ a ]であるクラスDのIPアドレスが使われています。(H20NW午後1問4)






参考までに、答えは以下です。ア コストイ データリンクa 224ではここで、OSPFの設定をCiscoルータの場合で紹介する。その意図は、どういう設定がされているかをみることで、理解を深めるためである。

ip routing ←ルーティングを有効にする
ip classless ←クラスレスルーティング
router ospf 1 ←1はプロセスIDで、複数のプロセスを持つ場合に使う。(あまり気にしない)
network 192.168.1.0 0.0.0.255 area 0 ←ルータが持つセグメントを記載する。今回のエリアは0
network 192.168.2.0 0.0.0.255 area 0

とてもシンプルで簡単です。

1  OSPFはコストを使った経路制御をすると思います。具体的には、どうやってコストを計算しますか?
次節で解説します。

(2)コストの計算方法

OSPFのコストは、出力側インタフェースのコスト値を積み上げて求める。入力と出力の両方ではないことに注意。手書きで恐縮であるが、以下のようなネットワークを考える。R1~R3はルータである。 R1からみた、10.1.1.0/24のコストはいくつか?以下の2パターンで計算してほしい。①R1→R2②R1→R2→R3ospf
女性直立①のコストは100÷帯域幅(Mbps)で計算されるため、10Mbpsの帯域幅のコストは10。よってR1のルータから、10.1.2.0/24ネットワークへのコストは10になります。
それだと、R2に届くまでのコストだね。10.1.1.0/24のネットワークまで通信するには、R2の右側の10Mの回線を通る必要があるから、ここのコストも加える必要がある。だから、10+10=20になる。同様に、②の場合、100Mbpsのコストは1であるため)、コストは1+1+10=12になる。また、①より②の方がコストが小さくなるため、R1→R3→R2という経路を選択する。この処理をOSPFは自動でやってくれるので、とても便利だ。・H28NW午後2問2でみてみよう。PCからデータセンタの経路のコストを考える。インターネットVPN経路、つまり PC→広域イーサ網→本社→インターネットVPN→データセンタの場合のコストはいくつかcost

正解は、以下をドラッグコスト値=50+10+220=280である。

■コストの変更
コストを自動計算してくれるのはとてもありがたいが、ときに手動でコストを変更させる必要がある。それはどんなときか。女性ほおづえ例えば10Mの帯域保証と10Mのベストエフォートでは、前者の方が高速だから手動でやるのですかね。
その通り。ネットワークスペシャリスト試験の過去問(H20NW午後1問4)でも、この点に関する出題があった。

各拠点のL3SWでは,経路制御プロトコルとしてOSPFを動作させます。OSPF では,[ ア ]と呼ばれるメトリックを扱います。L3SWでは,物理ポートの通信速度から計算された値がメトリックのデフォルト値になりますが,拠点間の経路選択を適切に行うために、①各処点のL3SWのポートの一つにはデフォルト値よりも大きな値を設定しておきます。
設問2 (1)本文中の[ ア ]に入れる適切な数値を答えよ。
 (2)本文中の下線①を行うのは,デフォルト値のままでは何の情報が反映されていないからか。






■試験センターの解答例設問1 ア コスト設問2 (2)拠点間の通信回線の実質的な回線速度の情報3なるほど。この点は理解できました。でも、コストの設定は、「L3SWのポート」に設定するんですね。最初の図でいうと、R1の右側のポートに設定するんですか?それとも、R1の右側と、R2の左側の両方に設定するんですか?
コストは、出るときにカウントUPされ、入ってくるときにはカウントUPされない。なので、「R1からみた、10.1.1.0/24のコスト」には、R2の左側のコストは、設定しても反映されない。シスコの設定例は以下である。

interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip ospf cost 10 ←コストの設定
(3)OSPFのコストの設計

次のような簡単なネットワークを考えましょう。本社とデータセンターを通信事業者が提供される1GbpsのWAN回線で接続しています。WAN1は品質が確保された広帯域な回線、WAN2は品質が担保されないベストエフォートの回線を契約したとします。 この場合、品質が高いWAN1を優先したいですよね。その設計をしてみましょう。 f:id:seeeko:20210501142449p:plain

まずは、OSPFの設定をします。
■ルータ1

router ospf 1  ←OSFPを有効に。
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0

■ルータ2

router ospf 1  ←OSFPを有効に。
network 192.168.4.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0

このとき、ルータ1のWAN1に接続されているポート1(GigabitEthernet 1)を見てみましょう。

Router#show ip ospf interface GigabitEthernet 1
GigabitEthernet 1 is up, line protocol is up (connected)
 Internet Address 192.168.2.253/24, Area 0
  Process ID 1, Router ID 192.168.2.253, Network Type BROADCAST, Cost: 1

このように、1Gbps回線なので、自動でCost1が割り当てられているのが確認できます。同様に、WAN2に接続されているポート2(GigabitEthernet 2)も同じくCostは1です。ネットワークスペシャリストを目指す女性SEかしげるこの場合、データセンター向けの通信は、WAN1とWAN2のどちらを通るのですか?
負荷分散される。つまり、WAN1とWAN2の両方に振り分けられます。では、このときのルーティングテーブルを見てみましょう。(OSPF部分だけ)

O 192.168.4.0/24 [110/2] via 192.168.2.254, 00:02:17, GigabitEthernet 1
          [110/2] via 192.168.3.254, 00:02:17, GigabitEthernet 2

このように、2つの経路が表示されています。つまり、両方の経路が有効になっているのです。 さて、ここで、[110/2]の2の値は、OSPFのコストであることは既に説明した通りです。なぜコストが1ではなくて2になるかを解説します。それは、ルータ1のインターフェースでCostが1加算され、ルータ2のインターフェースでもCostが1加算されるので、合計2になるのです。 ではここで、ポート1(GigabitEthernet 1)が接続されているWAN1を優先したいので、ポート2(GigabitEthernet 2)のコストを10にしてみましょう。

Router(config)# interface GigabitEthernet 2
Router(config-if)#ip ospf cost 10

もう一度、インターフェースのCostを見てみます。

Router#show ip ospf interface GigabitEthernet 2
GigabitEthernet 2 is up, line protocol is up (connected)
 Internet Address 192.168.3.253/24, Area 0
 Process ID 1, Router ID 192.168.3.253, Network Type BROADCAST, Cost: 10

設定した通り、コストが10になりました。 続けて、ルーティングテーブルを見てみましょう。

O 192.168.4.0/24 [110/2] via 192.168.2.254, 00:05:08, GigabitEthernet 1

今度は、優先度が高いWAN1の回線であるポート1(GigabitEthernet 1)の経路情報だけになっています。 では、ここで、WAN1のケーブルを切断しましょう。そして、あらためて経路情報を確認します。

O 192.168.4.0/24 [110/11] via 192.168.3.254, 00:06:51, GigabitEthernet 2

すると、今度は、WAN2の回線であるポート2(GigabitEthernet 2)が有効になっていることが分かります。

(4)ECMPによる冗長化

・ECMP(Equal Cost Multi-path)は、ルーティングにおける負荷分散の仕組みです。最適経路が複数ある場合に,経路を分散してパケットを転送します。これにより、経路の冗長化と負荷分散の両方を実現します。ECMPは、OSPFに限らず、RIPや静的経路でも利用できます。また、ECMPの設定は基本的には不要で、等コストであれば自動で負荷分散します。

・ECMPの動作モードとして,パケットモードとフローモードがある。 

通常どちらを使うかですが、通信品質の影響が少ないフローモードを使います。通信の偏りですが、経路制御は「フローモードの場合は、送信元IPアドレスと宛先IPアドレスからハッシュ値を計算して経路選択を行う(R4NWPM2-1)」仕組みです。ネットワークの構成次第ですが、送信元IPと宛先IPが変われば経路が変わるので、多くの場合は自然に偏らないと思われます。

(5)OSPFへデフォルトルート

・R3PM1-2設問2では、「OSPFへデフォルトルートを導入する」という問題がありました。
・OSPFは動的ルーティングで、デフォルトルートはスタティックルートです。ルーティングプロトコルが異なるので、OSPFでは再配信されません。そこで、以下のような設定をします。

R1#conf t
ip route 0.0.0.0 0.0.0.0 192.168.1.99 ←スタティックルートの記載
router ospf 1
default-information originate   ←OSPFへデフォルトルートの配信
end

3.DRとBRR

(1)概要

1つのセグメントに複数のルータが存在します。OSPFでは、LSA(Link-State Advertisement)という「リンク情報広告」によって、経路情報を交換します。すべてのルータが経路交換をするのは無駄だし、トラヒックが莫大になる。そこで、そのセグメント内で、経路情報の交換(LSAの交換)をするルータとしてDRとBDRを決める。そして、エリア内に各1つずつ選出されたDRとBDRとのみ、リンク情報を交換する。ネットワークスペシャリストを目指す女性SEハテナ DRとBDRは、エリアに一つなのですか?
いえ、セグメントごとに1つです。なので、エリアは通常の場合、複数のセグメントを持つことでしょうから、エリアの中に複数のDRとBDRが存在することになるでしょう。

(2)ルータの名称
名称 説明
DR (Designated Router) 代表ルータ
BDR (Backup DR) バックアップ代表ルータ
DROTHER その他、DRやBDRにならなかったルータ
(3)DRとBDRの選出方法

・OSPFのPriority(優先度)が高い(=値が大きい)ルータから順に、DR、BDRになります。
・Priorityは、0から255までの任意の値を設定できます。初期値は1です。これを0にすると、DR/BDRにはなりません。
・Priorityが等しいときは、ルータID(手動で設定)の大きい順で決まります。ただし、あくまでもこれはすべてのルータが起動している状態の場合です。優先度が高いルータがあとから起動しても、DRにはなりません。ですから、電源を入れるタイミングは重要です。
ネットワークスペシャリスト試験の過去問(H30NW午後1問3)では以下の記載がありました。

“スポークとなる機器がOSPFの代表ルータに選出されてしまうと,スポーク拠点間のIPsecトンネルが解放されなくなってしまうので,それを防ぐために,スポークとなる機器のOSPFに追加の設定が必要になる”というものであった。そこで,Eさんは,防止策として⑧追加すべき設定内容を定めた。

設問では、「追加すべきOSPFの設定」が問われました。正解は、「OSPFのプライオリティを0に設定する」です。
・Ciscoルータでの設定を紹介します。OSPFのプライオリティを0にするには、OSPFを広告するWANのインターフェースで、以下のコマンドを実行します。

Router(config)#int gi0
Router(config-if)#ip ospf priority 0
(4)DRとBDRの設定をみてみよう

OSPFを動作させているインターフェースで状態を確認します。以下は、「State DR, Priority 1」とりますので、代表ルータDRであり、Priorityが1であることがわかります。

R2#sh ip ospf interface GigabitEthernet 0
GigabitEthernet0 is up, line protocol is up
  Internet Address 192.168.1.102/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 192.168.1.102, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1

https://drive.google.com/file/d/16-TRMXtFOaQpz4ZkOQ_4tK86rvsdCKri/view?usp=sharing

4.CiscoによるOSPFのルーティング設定

ここでは、OSPFによるルーティングの設定をやってみます。

(1)ルーティングテーブルをみてみよう

ネットワーク構成は以下です。 ルーティングの具体例
 

ルータは、最適な経路を判断するために、宛先の経路情報を管理するルーティングテーブルを持っています。実際のルーティングテーブルをお見せする前に、先の図の場合のルータ1の設定を見てみましょう。以下がCiscoルータの設定(抜粋)です。

interface GigabitEthernet1   ←図のポート1
  ip address 192.168.1.254 255.255.255.0interface GigabitEthernet2   ←図のポート2
 ip address 192.168.2.254 255.255.255.0interface GigabitEthernet3   ←図のポート3
 ip address 192.168.3.254 255.255.255.0

設定を少し補足します。「interface GigabitEthernet」というのは1Gbpsの速度を持つインターフェースという意味です。3つのインターフェースそれぞれにIPアドレスが割り当てられています。  このように、ルータの各インターフェースには、IPアドレスおよびサブネット情報が設定されています。ですから、ルータに直接接続されているネットワークの情報をすでに知っています。  では、先のネットワーク構成図の場合、ルータ1のルーティングテーブル(経路情報)はどうなるでしょうか。Ciscoのコマンドを入力して確認しましょう。

Router1#sh ip route ・・・
C 192.168.1.0/24 is directly connected, GigabitEthernet1
C 192.168.2.0/24 is directly connected, GigabitEthernet2
C 192.168.3.0/24 is directly connected, GigabitEthernet3

■ルータ1のルーティングテーブル
では、この意味について解説します。 1.ルーティングテーブル
①Cは②で解説する直接接続(connected)のC ②172.16.1.0/24のネットワークはルータに直接(directly)に接続(connected) ③ルータに接続するポートがFastEthernet0 今回のルーティングテーブル(経路情報)はどうやって作るのでしょうか? ネットワークスペシャリストを目指す女性SEかしげるルータは直接接続されているネットワークを知っているので、ルータが自ら作成するのでしょうか。
その通り。このルィンググンブテーブルは自動で作成されます。では、直接接続されていないネットワークおよび、その場合のルーティングについて、次の節で解説します。

(2)直接接続されていないネットワークのルーティング

 ネットワークは世界中にありますから、ルータに直接接続されていないことがほとんどです。むしろ、直接接続されている方が稀です。 以下の図を見てください。ルータ1は、192.168.4.0/24のネットワーク宛のパケットはルータ2に送り、192.168.5.0/24宛てのパケットはルータ3に送るという経路制御をします。 2.ルーティングの具体例
 しかし、192.168.4.0/24や192.168.5.0/24のネットワークは、ルータ1に直接接続されていません。この場合のルーティングテーブルは、ルータ1は知り得ません。どうすればいいのでしょうか。ネットワークスペシャリストを目指す女性SEほおづえ  ルータに覚えさせるしかないと思います。
 その通りです。ルータに覚えさせる具体的な方法は2つあります。1つは,ネットワークの管理者がルーティング情報をルータに手動で記載する方法です。これをスタティックルーティング(静的ルーティング)と言います。スタティック(Static)とは、「静的」という意味です。  もう1つは,情報を知っている他のルータに教えてもらいます。具体的には,ルータ同士で経路情報を交換することで,ルーティングテーブルに自動で記載するのです。これをダイナミックルーティング(動的ルーティング)といいます。ダイナミック(dynamic)とは、「動的」という意味です。

(3)スタティックルーティング

ルータ1に静的な経路(スタティックルート)を書いてみましょう。具体的には、192.168.4.0/24宛てのパケットが来たら、宛先のルータ(ネクストホップと言います)として、ルータ2(IPアドレスは192.168.2.254)に送るという情報を記載します。 では、Ciscoルータで以下のコマンドを実行します。3.スタティックルーティング
①宛先のネットワーク ②ネクストホップとなるルータのIPアドレス  今回は、192.168.5.0/24宛てのネットワークもあるので、もう一行、「ip route 192.168.5.0 255.255.255.0 192.168.3.254」も記載します。 ルータ1に設定したConfigは以下になります。

ip route 192.168.4.0 255.255.255.0 192.168.2.254 ←192.168.4.0/24宛ての経路情報
ip route 192.168.5.0 255.255.255.0 192.168.2.254 ←192.168.5.0/24宛ての経路情報

■CiscoルータのConfig(インターフェース情報とスタティックルート)
ここで、show ip routeコマンドで、ルーティングテーブルを見てみましょう。

Router1#sh ip route
 ・・・
C 192.168.1.0/24 is directly connected, GigabitEthernet1
C 192.168.2.0/24 is directly connected, GigabitEthernet2
C 192.168.3.0/24 is directly connected, GigabitEthernet3
S 192.168.4.0/24 [1/0] via 192.168.2.254
S 192.168.5.0/24 [1/0] via 192.168.3.254

■ルータ1のルーティングテーブル
Sと書かれたルーティングテーブルについて解説します。 3.スタティックルーティング_2
①Sはスタティックルート(static route)のS
②192.168.4.0/24のネットワーク宛の経路
③1/0とありますが、前者の1は、アドミニストレーティブディスタンス値で、優先度を表します。たとえば、同じ宛先の経路情報が複数あった場合、数字が低い方が優先されます。スタティックは1、OSPFは110、RIPは120などと決められています。後者の0は、メトリックです。経由するルータの数と考えてください。すぐ隣のルータなので、経由するルータの数は0です。
④ネクストホップとなるルータのIPアドレス viaは、「~を経由して」という意味 に接続するポートがFastEthernet0 

この情報をまとめると、以下になります。

宛先ネットワーク ネクストホップ インターフェース
C 192.168.1.0/24 - GigabitEthernet1
C 192.168.2.0/24 - GigabitEthernet2
C 192.168.3.0/24 - GigabitEthernet3
S 192.168.4.0/24 192.168.2.254 -
S 192.168.5.0/24 192.168.3.254 -
(4)OSPFの設定

では、OSPFの設定を紹介します。Ciscoルータで以下のコマンドを実行します。4.OSPFの設定
 少し補足します。1行目は、OSPFを有効にするコマンドです。(※数字の1はプロセスIDですが、特に意識する必要はありません。)2~4行目は、ルータ1が知っているネットワークで、他のルータと経路を交換したいネットワークを記載します。RIPと違い、サブネットマスクも指定します。ですが、ワイルドカードとう0と1を逆にした表記方法を使います。たとえば、255.255.255.0のを2進数で表すと111111111111111100000000なので、これの0と1を逆にします。00000000000000000000000011111111になります。これを10進数表記にすると、0.0.0.255になります。また、最後にエリアIDを付けます。  RIPのときと同様に、各ルータでこれらの設定をします。すると、RIPと同様に、ルータ同士がお互いに経路を交換してくれます。 ではここで、show ip routeコマンドで、ルータ1のルーティングテーブルを見てみましょう。

Router1#show ip route
 ・・・
C 192.168.1.0/24 is directly connected, GigabitEthernet1
C 192.168.2.0/24 is directly connected, GigabitEthernet2
C 192.168.3.0/24 is directly connected, GigabitEthernet3
O 192.168.4.0/24 [110/2] via 192.168.2.254, 00:03:01, GigabitEthernet2
O 192.168.5.0/24 [110/2] via 192.168.3.254, 00:01:47, GigabitEthernet3
O 192.168.6.0/24 [110/2] via 192.168.3.254, 00:01:47, GigabitEthernet3
                               [110/2] via 192.168.2.254, 00:03:01, GigabitEthernet2

■ルータ1のルーティングテーブル
では、Rと書かれたルーティングテーブルについて解説します。4.OSPFの設定_2
①OはOSPFのO
②192.168.4.0/24のネットワーク宛の経路
③110/2とありますが、前者の1は、アドミニストレーティブディスタンス値で、優先度を表します。後者の2はOSPFの場合はコスト(※後述)を意味します。
④ネクストホップとなるルータのIPアドレス viaは、「~を経由して」という意味
⑤経路情報を学習してからの経過時間
⑥パケットを出力するインターフェース

 この情報をまとめると、以下になります。

宛先ネットワーク コスト ネクストホップ インターフェース
C 192.168.1.0/24 - - GigabitEthernet1
C 192.168.2.0/24 - - GigabitEthernet2
C 192.168.3.0/24 - - GigabitEthernet3
O 192.168.4.0/24 2 192.168.2.254 GigabitEthernet2
O 192.168.5.0/24 2 192.168.3.254 GigabitEthernet3
O 192.168.6.0/24 2 192.168.3.254
192.168.2.254
GigabitEthernet3
GigabitEthernet2
(5)RIPとOSPFの経路変更時間の違い

 RIPは,定期的な情報交換(レギュラーアップデート)として,30秒間隔で経路情報を交換し、実際に経路情報が変更されるには,さらに時間がかかります。先のルータが3台の構成で、インターフェースがダウンした際に、経路が切り替わるのに3分以上かかりました。一方のOSPFの場合、経路情報の交換は10秒ごとでして、RIPと同じ障害を起こした場合に、切り替わるまでの時間は10秒ちょっとでした。
❶RIPの場合
タイムアウトが3分以上続く

❷OSPFの場合
タイムアウトになったのは2回だけで、10秒少々でネットワークが復旧

5.ルーティングの基礎問題

以下の構成においてそれぞれのネットワークと通信できるようにルーティングを設定する


※ルータ2のIPアドレスは、192.168.2.254と192.168.4.254、ルータ3のIPアドレスは、192.168.3.254と192.168.5.254
以下、理解をふかめてもらうための漠然とした質問です。なるべく詳しく回答ください。 

Q1.ルータ1にスタティックルートを書く場合、
 (1)どんな内容を記載するか。
 (2)ルーティングテーブルはどうなるか。
 (3)アドミニストレーティブディスタンス値を確認せよ。






A1.(3)スタティックルーティング

Q2.ルータ1にOSPFで経路を書く場合、
 (1)どんな内容を記載するか。
 (2)ルーティングテーブルはどうなるか。
 (3)アドミニストレーティブディスタンス値を確認せよ。
 (4)コストはいくつになるか。






A2.(4)OSPFの設定